XiaBee's Studio.

安装 docker-compose 2
前期提要上期我们讲到,postal的安装需要高版本的docker-compose。 一般情况下,我们直接使用包管理安装即可,但是我在安装过程中遇到了包管理器中没有高版本的情况……所以写下本篇记录一下。 本篇依然以Ubuntu/Debian为例。 查看版本1docker-compose -v 此时看到我们的版本是1.25.0,是低于2.0的,无法运行3.9及以上的docker-compose.yml 安装方式(一) 可以参考官网 这里使用一种比较暴力的安装方式:直接手动下载可执行文件 查看最新版本浏览器访问docker-compose的代码仓库(可能需要翻墙) 截至目前,最高版...
Docker 搭建 Postal 邮件系统
前情提要上次搭建了一个Hydro-OJ,注册需要邮箱验证,想着要不一步到位顺带把邮件系统也处理了(x) 系统选择有很多酷炫且开源的邮件系统,github上能搜到很多,比如mailcow,postal等。本片主要介绍postal的搭建方式。 Postal 简介 官网:postal 项目地址:GitHub - postalserver/install Postal is a complete and fully featured mail server for use by websites & web servers. Think Sendgrid, Mailgun or...